silverton's RS-T [now with smaller pictures, sorry!] - Page 17 - Subaru Impreza GC8 & RS Forum & Community: RS25.com
 
Private Support i-Trader Ratings Become a Vendor Rules for VendorsModsUsers Contact
Subaru Impreza GC8 & RS Forum & Community: RS25.com
gc8 RSS GC8 Facebook Subaru GC8 Twitter Subaru YouTube Channel Subaru Sticker
 
Login below or Register Now
Register Mark Forums Read FAQ Advertise
Go Back   Subaru Impreza GC8 & RS Forum & Community: RS25.com > >
silverton's RS-T [now with smaller pictures, sorry!]
Reply
 
Thread Tools Display Modes
Old 06-25-2019, 01:45 PM   #161
silverton
2.0L Turbo
 
Fav Mod: turrrrrbbbbooooo
Join Date: Aug 2012
Location: Burien, WA
Trader Rating: (0)
Posts: 1,136
Default

I was able to find that the 2.2L has this branch that goes to the ecm. the 2.5 does not when you go in to the full engine diagram instead of the dtc diagnostics.


But, I'm done with this thing. I'm not having fun any more. I tested every wire in the circuit and there's continuity everywhere, and 12v is making it to the rear O2.
__________________
2001 STM AutoMagic - boost for as long as I keep my foot down

Last edited by silverton; 06-27-2019 at 05:47 AM..
silverton is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-26-2019, 01:05 PM   #162
SoCoNoHa
2.7L
 
Fav Mod: Anything custom
Join Date: Feb 2018
Location: Southern NH
Trader Rating: (1)
Posts: 356
Default

Dude, ship me your harness, I'll figure that sumbitch out. I'd hate to see another thread go down this path.

Seriously, I love playing with wires.
__________________
92 SVX / 95 GM2 / 02 GDE / 03 GDA
SoCoNoHa is offline   Reply With Quote
Old 06-27-2019, 06:01 AM   #163
silverton
2.0L Turbo
 
Fav Mod: turrrrrbbbbooooo
Join Date: Aug 2012
Location: Burien, WA
Trader Rating: (0)
Posts: 1,136
Default

I replaced the head light switch last night. Thankfully the only damage was to the head light switch itself. I'm should try another new O2 sensor. I replaced both front and rear with Denso's earlier in the year. I say this all the time, just because it's new doesn't mean it's good, and maybe it's biting me in the ass here. WA State is doing away with emissions testing, I could just pull the bulb and ignore it! It seems to make the car target 14.0-14.4 though but still gets 20+mpg if I don't get in to boost.


I appreciate that offer soconoha! I will keep it in mind as I absolutely despise wires.
__________________
2001 STM AutoMagic - boost for as long as I keep my foot down

Last edited by silverton; 06-27-2019 at 06:06 AM..
silverton is offline   Reply With Quote
Old 06-30-2019, 06:03 PM   #164
silverton
2.0L Turbo
 
Fav Mod: turrrrrbbbbooooo
Join Date: Aug 2012
Location: Burien, WA
Trader Rating: (0)
Posts: 1,136
Default

Took the O2 extender out today to see if that was my O2 sensor issue. Didn't help. Went and bought a new bosch sensor. didn't help. just throwing money at it at this point, maybe i'll see if I can get a new O2 sensor cord...
__________________
2001 STM AutoMagic - boost for as long as I keep my foot down
silverton is offline   Reply With Quote
Old 07-03-2019, 09:27 AM   #165
silverton
2.0L Turbo
 
Fav Mod: turrrrrbbbbooooo
Join Date: Aug 2012
Location: Burien, WA
Trader Rating: (0)
Posts: 1,136
Default

We got a good rain after a bit of a dry spell, and my car was still RWD. The car is very tail happy, especially with booooost. Only down side is that it likes to lift a rear wheel if you flick it too hard.

a little RWD action - YouTube

I was gettin it a little bit and had a butt hole puckering moment as I was getting on to a freeway with a bridge transition. Essentially got the speed wobbles, thought it was gonna let go but was able to recover. So.... I replaced that front axle last night, and in doing so I noticed there was a little yellow loom with some mangledness to it. Yellow = airbag.

The blue one was only unsheathed, still connected no frayed strands but very dirty so it's been like this for awhile. The tan one was cut with many strays. Explains the intermittent airbag light I had for some time and why it finally became steady.




It'll be amazing if this grounding itself on the chassis was dicking with the rear O2 circuit, but I don't have my hopes too high for that.
__________________
2001 STM AutoMagic - boost for as long as I keep my foot down
silverton is offline   Reply With Quote
Old 07-04-2019, 09:32 PM   #166
bue car
#32
 
bue car's Avatar
 
Fav Mod: Which car?
Join Date: Jun 2008
Location: Torrance, CA
Trader Rating: (173)
Posts: 11,685
Default

Splish splash!
__________________
Group C Performance - Feel free to follow me, I'll start posting car stuffs - @cdrong32
bue car is offline   Reply With Quote
Old 07-05-2019, 01:16 AM   #167
SoCoNoHa
2.7L
 
Fav Mod: Anything custom
Join Date: Feb 2018
Location: Southern NH
Trader Rating: (1)
Posts: 356
Default

Do you know what caused your harness to get so great up, have you had a blowout on that wheel or something? I had damage in the same spot after introducing my '02 to a guardrail...

And yeah I don't think that section of harness has anything to do with O2, but it makes a good case for checking the rest of your harnesses!
__________________
92 SVX / 95 GM2 / 02 GDE / 03 GDA
SoCoNoHa is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:04 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 2019 VerticalScope Inc.
Designed & Powered by Domain Architect