181stLeader's World Rally Blue Widebody Coupe! - Page 7 - Subaru Impreza GC8 & RS Forum & Community: RS25.com
 
Private Support i-Trader Ratings Become a Vendor Rules for VendorsModsUsers Contact
Subaru Impreza GC8 & RS Forum & Community: RS25.com
gc8 RSS GC8 Facebook Subaru GC8 Twitter Subaru YouTube Channel Subaru Sticker
 
Login below or Register Now
Register Mark Forums Read FAQ Advertise
Go Back   Subaru Impreza GC8 & RS Forum & Community: RS25.com > >
181stLeader's World Rally Blue Widebody Coupe!
Reply
 
Thread Tools Display Modes
Old 11-30-2011, 10:53 PM   #61
181stLeader
Premium Member
 
181stLeader's Avatar
 
Fav Mod: Aerosim Carbon Widebody
Join Date: Apr 2010
Location: The OC
Trader Rating: (14)
Posts: 1,519
Default

Quote:
Originally Posted by 2 Door View Post
Nice, def worth doing all that. That twin scroll should be fun in auto-cross.
Yeah, I'm hoping so. I have heard that there is almost no lag, transient boost response is great on the twin scrolls. we'll see.

Plus I have been driving my 1.8L powered L and a 3 cylinder geo metro(both have less than 100 hp LOL) for the past few months so once the engine is in my L it will feel like the fastest car in the world.
181stLeader is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-05-2011, 09:49 PM   #62
jbug
2.2L
 
Fav Mod: Dccdpro
Join Date: May 2011
Location: los angeles
Trader Rating: (2)
Posts: 172
Default

So your engine arrived where are the pictures holmes
jbug is offline   Reply With Quote
Old 12-05-2011, 10:59 PM   #63
2 Door
I ❤ BOOBIES
 
Fav Mod: A career
Join Date: May 2009
Location: Socal
Trader Rating: (18)
Posts: 2,115
Default

Dont you worry, it will be up soon, I just saw a picture of it... its beautiful.
2 Door is offline   Reply With Quote
Old 12-09-2011, 01:08 AM   #64
181stLeader
Premium Member
 
181stLeader's Avatar
 
Fav Mod: Aerosim Carbon Widebody
Join Date: Apr 2010
Location: The OC
Trader Rating: (14)
Posts: 1,519
Default

My engine got here last Friday I have made some progress so I figure why not update my journal!

I have stripped the whole interior and started the install of the freshly merged 99 rs to 02 wrx harness(with AVCS and gc cluster plugs) from IWIRE.


I was always horrified at peoples pics of the wiring when they are doing a swap because of how intimidating hooking everything up looks. Now that I am going though it its not that bad because almost everything can only plug in one place.



Rear harness being installed:



I noticed that there was a scuff on the lower left timing cover of my EJ207 when it got here but I didn't think that it was that big of a deal since it was not cracked:


I removed the timing covers to verify cam timing on my motor and install my Tomioka Racing Timing Belt guide that I won at subiefest like 2 years ago.

Last edited by 181stLeader; 12-09-2011 at 01:21 AM..
181stLeader is offline   Reply With Quote
Old 12-09-2011, 01:18 AM   #65
181stLeader
Premium Member
 
181stLeader's Avatar
 
Fav Mod: Aerosim Carbon Widebody
Join Date: Apr 2010
Location: The OC
Trader Rating: (14)
Posts: 1,519
Default

When I was checking cam timing I found this:







It is just a small chip and no cracks. After talking to my friend who is a tech at Puente Hills Subaru I decided to just replace the cam gear just to be safe. I also contacted the vendor I got the engine from to file a claim with the shipping company so I could be reimbursed for the cost of the cam gear. It was only $100 for the cam gear(and glendale subaru had one in stock), it would really suck it the cam gear later cracked and ruined my new motor.


Swapping the cam gear was easier that I thought it would be, I was always scared to do a timing belt on a DOHC suby. I followed Meatys timing belt changing guide on nasioc and it was pretty easy. After buttoning up the timing belt after the cam gear change I dropped the EJ207 in its new home:
181stLeader is offline   Reply With Quote
Old 12-09-2011, 10:22 AM   #66
jbug
2.2L
 
Fav Mod: Dccdpro
Join Date: May 2011
Location: los angeles
Trader Rating: (2)
Posts: 172
Default

So when are we starting this thing up???
jbug is offline   Reply With Quote
Old 12-09-2011, 12:22 PM   #67
2 Door
I ❤ BOOBIES
 
Fav Mod: A career
Join Date: May 2009
Location: Socal
Trader Rating: (18)
Posts: 2,115
Default

How the hell did the cam gear get scuffed like that if the timing belt cover was on and wasn't cracked?
2 Door is offline   Reply With Quote
Old 12-09-2011, 01:39 PM   #68
Spec R
3.3L
 
Fav Mod: CA BAR sticker
Join Date: Jan 2010
Location: Monrovia, CA
Trader Rating: (5)
Posts: 946
Default

wow i really wish i could have helped out, but im so busy with work lately. nice work man
Spec R is offline   Reply With Quote
Old 12-09-2011, 05:35 PM   #69
181stLeader
Premium Member
 
181stLeader's Avatar
 
Fav Mod: Aerosim Carbon Widebody
Join Date: Apr 2010
Location: The OC
Trader Rating: (14)
Posts: 1,519
Default

Quote:
Originally Posted by jbug View Post
So when are we starting this thing up???
Hopefully soon. I need a few more parts, GD throttle cable(My stock DP gets here in the 13th), and various hoses.

Quote:
Originally Posted by 2 Door View Post
How the hell did the cam gear get scuffed like that if the timing belt cover was on and wasn't cracked?
I know! that's what I said. That's why I didn't think much of it when the UPS guy dropped it off. Glad I checked the timing tho because I wouldn't want that gear to assplode later on. The gear actually has a chip taken out of it. I found the broken off piece chilling in the bottom of the timing cover.

Quote:
Originally Posted by Spec R View Post
wow i really wish i could have helped out, but im so busy with work lately. nice work man
No worries, most of it hasn't been too bad, getting the wiring all sorted was the biggest challenge. I'm sure you know what I mean since you had to rewire your whole car.
181stLeader is offline   Reply With Quote
Old 12-16-2011, 12:42 AM   #70
181stLeader
Premium Member
 
181stLeader's Avatar
 
Fav Mod: Aerosim Carbon Widebody
Join Date: Apr 2010
Location: The OC
Trader Rating: (14)
Posts: 1,519
Default

Just thought I'd update the journal. Started the engine for the first time tuesday. It fired right up after I remembered to plug in the STi loom into the fuel pump.

I'd like to thank Iwire for the awesome merge and for the help with various plugs and where they go. So far everything is working perfect wiring wise. IWire FTW!

Yesterday and today I spent neatening up wiring in the engine bay and in the dash section. Also got the keyless entry module wired up. 95 Impreza L with keyless entry FTW!

I still need to adjust the tie rods since they are way too long since the rack is off a GD STi, start reassembling the front end(fenders bumper, lights), my USDM sti cat back is too short for my JDM downpipe so I bought an adapter pipe from a member here.

Last edited by 181stLeader; 09-30-2012 at 01:31 AM..
181stLeader is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:12 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 2019 VerticalScope Inc.
Designed & Powered by Domain Architect