Misfiring - Subaru Impreza GC8 & RS Forum & Community: RS25.com
 
Private Support i-Trader Ratings Become a Vendor Rules for VendorsModsUsers Contact
Subaru Impreza GC8 & RS Forum & Community: RS25.com
gc8 RSS GC8 Facebook Subaru GC8 Twitter Subaru YouTube Channel Subaru Sticker
 
Login below or Register Now
Register Mark Forums Read FAQ Advertise
Go Back   Subaru Impreza GC8 & RS Forum & Community: RS25.com > >
Misfiring
Reply
 
Thread Tools Display Modes
Old 04-08-2011, 02:41 PM   #1
G_2.5rs
2.7L
 
Car: 99 rs
Fav Mod: Borla headers
Join Date: Feb 2008
Location: mpls,mn
Trader Rating: (1)
Posts: 349
Default Misfiring

At the beginning of the week my car started misfiring and gave it a horrible sluggish acceleration. Was told to check the plugs and saw that there was oil in there so i replaced the plugs, wires, and gaskets. But after that the problem is still there and made no difference at all. It would be very sluggish almost stalling at time when engaging into 1st and sometimes it would run right for a second then back to the sluggish feel. Idle is very low.. 400 at times It will sometimes go away on highway drives and will come back very quickly as soon as i slow down. I am going to get the cel code tonight and will check the MAF tomorrow. Current mods are:

ebay borlas
gms catback
torque box short ram intake
paranoid fab grnd wires

Recently done maitenence:
Clutch
spark plugs n wires
valve cover gasket
spark plug seals
oil change

Anyone have any suggestions?
G_2.5rs is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-08-2011, 06:12 PM   #2
G_2.5rs
2.7L
 
Car: 99 rs
Fav Mod: Borla headers
Join Date: Feb 2008
Location: mpls,mn
Trader Rating: (1)
Posts: 349
Default

bump, doesnt seem to be the maf, as when i unplugged it while the car was still on it got way worst. my person couldnt find his code reader so until he does idk what codes are being thrown atm.
G_2.5rs is offline   Reply With Quote
Old 04-09-2011, 08:19 PM   #3
yarrgh
3.3L
 
Car: Black 2001 RS
Fav Mod: larger rear brakes
Join Date: Feb 2005
Location: Denver
Trader Rating: (0)
Posts: 781
Default

I see you replaced the spark plug seals, is there still oil in the tubes? Did you reset the ECU after the plugs? Bad tank of gas?
__________________
Who is John Galt?
yarrgh is offline   Reply With Quote
Old 04-10-2011, 06:58 AM   #4
G_2.5rs
2.7L
 
Car: 99 rs
Fav Mod: Borla headers
Join Date: Feb 2008
Location: mpls,mn
Trader Rating: (1)
Posts: 349
Default

found out the misfiring issue. one of the big plugs under the torque box came loose and the misfiring went away. But now another issue came up. pulled the codes and i got:

P0102 Mass air flow sensor circuit low input

P1510 ISC Solenoid Valve Signal #1 Circuit Malfunction (Low Input)
P1514 ISC Solenoid Valve Signal #3 Circuit Malfunction (Low Input)
P1516 ISC Solenoid Valve Signal #4 Circuit Malfunction (Low Input)
P1507 Idle Control System Malfunction (Fail-safe)
P0446 evap drain system circuit malfunction

car idles extremely low(200) and dies everytime im in reverse.

tried to take out my iac valve to clean it but the screws are starting to strip and cant get it off. any suggestions?
G_2.5rs is offline   Reply With Quote
Old 04-10-2011, 07:28 AM   #5
Pal208m
Resident ovloV Guru
 
Pal208m's Avatar
 
Fav Mod: Rally Armor Mudflaps
Join Date: Oct 2008
Location: Kingston,NY
Trader Rating: (11)
Posts: 3,077
Default

Yoyur car is not idel at 200. An engine cannot run at that low of an RPM. As for the spark plugs, you said that you had oil on them and this is when your problem started after your oil change. Did you overfill the crank case?
Pal208m is offline   Reply With Quote
Old 04-10-2011, 05:04 PM   #6
G_2.5rs
2.7L
 
Car: 99 rs
Fav Mod: Borla headers
Join Date: Feb 2008
Location: mpls,mn
Trader Rating: (1)
Posts: 349
Default

if it aint 200 then its definitely near it. and no i didnt overfill the crankcase.
G_2.5rs is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:18 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 2019 VerticalScope Inc.
Designed & Powered by Domain Architect