Obd2 not working - Subaru Impreza GC8 & RS Forum & Community: RS25.com
 
Private Support i-Trader Ratings Become a Vendor Rules for VendorsModsUsers Contact
Subaru Impreza GC8 & RS Forum & Community: RS25.com
gc8 RSS GC8 Facebook Subaru GC8 Twitter Subaru YouTube Channel Subaru Sticker
 
Login below or Register Now
Register Mark Forums Read FAQ Advertise
Go Back   Subaru Impreza GC8 & RS Forum & Community: RS25.com > >
Obd2 not working
Reply
 
Thread Tools Display Modes
Old 06-29-2019, 07:21 AM   #1
Vinnyevil1
1.8L
 
Car: 1999 subaru rs ej25 hybrid
Join Date: Jun 2019
Trader Rating: (0)
Posts: 20
Default Obd2 not working

Hey guys I have a 99rs with a 2002 swap that I bought. The obd2 doesn't work and the check engine and abs lights are on this is a pic of the obd2 port wires and the ecu. Can anyone help why I can't get a connection??
Vinnyevil1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-02-2019, 03:36 PM   #2
IWire
Premium Vendor
 
IWire's Avatar
 
Fav Mod: Swap
Join Date: Nov 2008
Location: Southern California
Trader Rating: (23)
Posts: 1,025
Default

Quote:
Originally Posted by Vinnyevil1 View Post
Hey guys I have a 99rs with a 2002 swap that I bought. The obd2 doesn't work and the check engine and abs lights are on this is a pic of the obd2 port wires and the ecu. Can anyone help why I can't get a connection??
Which 2002 is it? USDM or JDM? WRX or STi or Legacy or etc? There's no picture attached.

Sometimes replacing the OBD2 Port can fix it but would need to know more info.

You could also be in test mode. Make sure the two green connectors under the dash are unplugged.
__________________
iWire Subaru Wiring Services
949-510-8278
www.iwireservices.com

Last edited by IWire; 07-02-2019 at 03:39 PM..
IWire is offline   Reply With Quote
Old 07-03-2019, 04:15 AM   #3
Vinnyevil1
1.8L
 
Car: 1999 subaru rs ej25 hybrid
Join Date: Jun 2019
Trader Rating: (0)
Posts: 20
Default

Thanks for the reply! I actually found you guys on youtube and watched all your videos yesterday! I'm trying to post a pic but it says it's to large. The ecu is for an automatic 02 wrx I believe. I bought the gc8 from my fr8end that didn't do that great of a job on the swap. Just want the obd2 to work so I can plug in. It's tuned on open-source I don't know if that disabled use of the port???
Vinnyevil1 is offline   Reply With Quote
Old 07-03-2019, 09:12 AM   #4
silverton
2.0L Turbo
 
Fav Mod: turrrrrbbbbooooo
Join Date: Aug 2012
Location: Burien, WA
Trader Rating: (0)
Posts: 1,156
Default

It shouldn't disable use of the port, as that is the port to reflash/tune it. I'm pretty sure I've read in a swap how-to faq that the obd2 port needs to be repinned when using a wrx ecu.
__________________
2001 RS+T - 2001 LGT
silverton is offline   Reply With Quote
Old 07-03-2019, 07:50 PM   #5
Vinnyevil1
1.8L
 
Car: 1999 subaru rs ej25 hybrid
Join Date: Jun 2019
Trader Rating: (0)
Posts: 20
Default

The ecu number is 22611af413 it says v1 in bold on top of that. Says automatic wrx ecu. I have been looking for a perfect obd2 pinout and i cant find anything online.
Vinnyevil1 is offline   Reply With Quote
Old 07-03-2019, 11:14 PM   #6
johnxx
2.5L
 
Car: '96 OBS
Fav Mod: EJ204!
Join Date: Jun 2011
Location: Bellingham, WA
Trader Rating: (2)
Posts: 210
Default

Ton of factory service manuals here: Index of /Auto/Japan/Subaru


Makes for relaxing bedtime reading.
johnxx is offline   Reply With Quote
Old 07-04-2019, 04:05 AM   #7
Vinnyevil1
1.8L
 
Car: 1999 subaru rs ej25 hybrid
Join Date: Jun 2019
Trader Rating: (0)
Posts: 20
Default

Thanks for the manuals, I have a different one but this is helpful. I still can't find wire diagram of obd2 pin out though.
Vinnyevil1 is offline   Reply With Quote
Old 07-04-2019, 08:05 PM   #8
Vinnyevil1
1.8L
 
Car: 1999 subaru rs ej25 hybrid
Join Date: Jun 2019
Trader Rating: (0)
Posts: 20
Default

Obd2 not working-20190628_094151_resized.jpg

Obd2 not working-20190629_101943_resized.jpgObd2 not working-20190628_094151_resized.jpg

Last edited by Vinnyevil1; 07-04-2019 at 08:11 PM..
Vinnyevil1 is offline   Reply With Quote
Old 07-04-2019, 08:05 PM   #9
Vinnyevil1
1.8L
 
Car: 1999 subaru rs ej25 hybrid
Join Date: Jun 2019
Trader Rating: (0)
Posts: 20
Default

thats what mine looks like atm. the side red and black is the positive and the two other ones are ground. why doesnt my obd2 read? it turns on but says not supported. the obd2 is just facing down thats why the power is on the top right, its on the bottom right when spun.

Last edited by Vinnyevil1; 07-04-2019 at 08:09 PM..
Vinnyevil1 is offline   Reply With Quote
Old 07-05-2019, 01:18 PM   #10
johnxx
2.5L
 
Car: '96 OBS
Fav Mod: EJ204!
Join Date: Jun 2011
Location: Bellingham, WA
Trader Rating: (2)
Posts: 210
Default

In the FSM Subaru calls that connector the "Data Link Connector" and in the 02 Impreza FSM it's connector B40. Grab the wiring section, flip to page WI-71 and you should spot the wires that need to route to the ECU. I'd unplug the ECU (and turn off the car) and check for continuity between the OBDII connector pins and the corresponding pins on the ECU connector.

A note on the FSM PDFs: It *looks* like you can search for text in them, but only some of the text is searchable. It kinda sucks flipping through pages looking for a reference to the thing you're looking for, but it beats not having it.
johnxx is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:43 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 2019 VerticalScope Inc.
Designed & Powered by Domain Architect