2.5RS Engine swap to EJ203 SOHC non turbo - Page 5 - Subaru Impreza GC8 & RS Forum & Community: RS25.com
 
Private Support i-Trader Ratings Become a Vendor Rules for VendorsModsUsers Contact
Subaru Impreza GC8 & RS Forum & Community: RS25.com
gc8 RSS GC8 Facebook Subaru GC8 Twitter Subaru YouTube Channel Subaru Sticker
 
Login below or Register Now
Register Mark Forums Read FAQ Advertise
Go Back   Subaru Impreza GC8 & RS Forum & Community: RS25.com > >
2.5RS Engine swap to EJ203 SOHC non turbo
Reply
 
Thread Tools Display Modes
Old 03-22-2017, 10:34 AM   #41
Scubanub
1.8L
 
Join Date: Feb 2013
Trader Rating: (1)
Posts: 48
Default

Update: Car threw CEL codes P0301 P0302. Got new spark plugs, wires and new front Denso o2. can drive roughly 150miles and it seems to come on again. Might need to buy coil pack. Also saw that i have an exhaust leak at the collector (doughnut gasket) after the cats. I've heard that this will cause misfires in cyl 1 and 2 for some odd reason. Will fix/repair, and report back.
Scubanub is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-31-2017, 05:55 AM   #42
cptnslick
1.8L
 
Join Date: Mar 2017
Trader Rating: (0)
Posts: 1
Default

@npstrs - have you done anything with ROMRAIDER yet?
cptnslick is offline   Reply With Quote
Old 05-01-2017, 05:15 AM   #43
kayen
1.8L
 
Car: 02 Bugeye STI & 03 Forester XS
Fav Mod: Spec C EJ207
Join Date: May 2006
Location: Kalamazoo, MI
Trader Rating: (0)
Posts: 4
Default

Quote:
Originally Posted by Scubanub View Post
Update: Car threw CEL codes P0301 P0302. Got new spark plugs, wires and new front Denso o2. can drive roughly 150miles and it seems to come on again. Might need to buy coil pack. Also saw that i have an exhaust leak at the collector (doughnut gasket) after the cats. I've heard that this will cause misfires in cyl 1 and 2 for some odd reason. Will fix/repair, and report back.
Were you able to resolve your issue?
kayen is offline   Reply With Quote
Old 03-12-2018, 07:50 AM   #44
TerryJr
Experimenter
 
TerryJr's Avatar
 
Fav Mod: AAA Premier
Join Date: Jun 2009
Location: Pittsburgh
Trader Rating: (0)
Posts: 3,676
Default

Just didnt his swap on a 2008 Impreza 2.5i. Swapped of the intake manifold and exhaust manifold. Left long block alone. Our Ej203 had TGV's. We had to open the ROM and delete the AVLS codes and now it runs like just fine. Without the codes deleted, the engine would cut out around 4k rpm, i assume thats when the AVLS would activate.
__________________
Why should we be paying to keep guy's like Chris Watts alive?
TerryJr is offline   Reply With Quote
Old 04-04-2018, 08:20 AM   #45
DashCoyote
1.8L
 
Car: 2005 RS wagon, EJ203 swapped
Join Date: Mar 2018
Location: Dallas, Texas
Trader Rating: (0)
Posts: 1
Default

Just did this swap on a 2005 Impreza RS. Only frustrating part was once we got the motor in, we realized the flex plate on the EJ203 was too small, so learn from my mistake and be sure to double check sizes.

Other than that it runs great! No codes, but fuel consumption is high. I did find a sticky caliper on the passenger rear, so hopefully that's what's causing the problem.
DashCoyote is offline   Reply With Quote
Old 05-21-2018, 09:12 AM   #46
bdobraj
2.0L
 
Car: 2005 Impreza RS 2.5
Join Date: Feb 2014
Trader Rating: (0)
Posts: 65
Default

Could use some help. Put in an ej203 in my 2005 impreza RS. Have it all back together but it will not start. Seems to be getting spark and fuel but still no start. Double checked all the sensors and is everything is plugged back in. I did replace the timing belt before changing the motor and made sure all marks were correct.

What do I check next?
bdobraj is offline   Reply With Quote
Old 05-21-2018, 11:08 AM   #47
postwarart
2.2L
 
Join Date: Sep 2013
Trader Rating: (0)
Posts: 182
Default

Did you swap the cam gears?.

Also, did you read all threads that have done this swap? I compiled all the ones I used (plus added info) here:

JDM NA EJ20 Swap Megathread
postwarart is offline   Reply With Quote
Old 05-21-2018, 10:25 PM   #48
bdobraj
2.0L
 
Car: 2005 Impreza RS 2.5
Join Date: Feb 2014
Trader Rating: (0)
Posts: 65
Default

Did not swap cam gears.

Found out the motor I got ahold of was junk. It was literally pouring coolant out of the exhaust ports in the exhaust and eventually leaking out of the muffler.
bdobraj is offline   Reply With Quote
Old 05-22-2018, 10:46 AM   #49
postwarart
2.2L
 
Join Date: Sep 2013
Trader Rating: (0)
Posts: 182
Default

Quote:
Originally Posted by bdobraj View Post
Did not swap cam gears.

Found out the motor I got ahold of was junk. It was literally pouring coolant out of the exhaust ports in the exhaust and eventually leaking out of the muffler.


Is the company you bought it from returning your money/offering a trade?
postwarart is offline   Reply With Quote
Old 06-06-2018, 06:45 PM   #50
UnderpoweredRS
aka RFoy2.5RS-T
 
UnderpoweredRS's Avatar
 
Car: 98 RS
Fav Mod: EJ205
Join Date: Aug 2004
Location: Stratford NJ
Trader Rating: (22)
Posts: 1,707
Default

What kind of gas mileage is everyone getting with these motors? My daily is an 01 forester. The motor is consuming oil and it feels like it's low on compression. I'm thinking the ej20 swap would be perfect for my beater. Currently getting around 24mpg hopefully the ej20 does a bit better. I don't care about it being fast or slow.
__________________
My GC8 Your STi
UnderpoweredRS is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:25 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 2019 VerticalScope Inc.
Designed & Powered by Domain Architect